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Online Comments
5.0

1.0 Introduction

Adobe Acrobat’s Online Comments feature allows multiple users to post comments on a single 
document. Users in an online commenting session can share their comments and view others’ 
comments in real-time, or users can comment on a document at their own convenience and upload 
their comments at a later time with the offline option. Remote users can comment on any PDF file.

Users do not alter the original document while commenting. Comments are saved in a repository 
outside of the document—maintaining the author’s control in revising the original document. To 
provide greater flexibility, a repository may be a database, a network folder, or a folder on the Web. 

There are four repository types for Online Commenting: 

• Network Folder

• Web Discussions

• Database

• WebDAV

This document provides a technical overview of the different repository types.

2.0 Configuring Your Online Comments Preferences

Each user must set the Online Comments Preferences before the collaboration session can begin. 
Users can manually set the Online Comments Preferences through Edit > Preferences > General > 
Online Comments. The server preferences will remain in effect until changed. 

Alternatively, a Network Administrator can create an FDF file for each repository type that will 
automatically set the server preferences for the user. This is useful for people who frequently 
comment on multiple documents. For ease of use, the administrator can place the FDF at a readily 
accessible location, such as a frequently used website. The user clicks on this FDF and is taken to 
another page which says that they have successfully set their online comments server settings. FDF 
refers to Acrobat’s Forms Data Format, which Acrobat uses to receive information from a server and 
fill in form fields as well as communicate with an Acrobat JavaScript engine. The second part of this 
functionality is what Online Comments uses to set the Online Comments server preferences. Sample 
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FDF files are given in the section for each repository type. Adobe strongly recommends that a 
Network Administrator create an FDF file to minimize errors.

Acrobat JavaScript methods can also be used to set the Online Comments Server type as well as the 
Online Comments Server settings (if applicable). This information is put in the FDF file. When 
Acrobat opens the file, the client's Online Comments settings will be applied. For more information 
on this topic, please see the Acrobat Solutions Network documentation, which is available at 
http://partners.adobe.com/asn.

Characteristics of each server type are described in the section by that name. There are, however, 
several elements of Online Comments that are consistent across server types. 

2.1 Identity

Since several users may be commenting on one document, user names are important to identify the 
person making a comment. To ensure that comments are attributed to the correct individuals, Acro-
bat automatically populates the User Name that appears as the Author Name in the comment prop-
erties dialog as well as in the title bar of the note pop-up. On Microsoft Windows systems, Acrobat 
uses the Windows login name. On Apple Macintosh systems, Acrobat uses either the login name or 
file sharing name, depending on which exists. User names are generally case sensitive, such that 
JPUBLIC is a different user than jpublic. See Configuring the WebDAV Repository for the only 
exception to this rule.

Note: If the user has by-passed the Windows login screen, the default user name is “GUEST.” 
This may cause confusion when the user uploads their comments. See the Security section 
for more information.

In the Network Folder and WebDAV repository types, when the login name contains something 
other than letters or numbers, Acrobat will encode the user name to translate the character to the 
hexadecimal representation of that character. For example: Comments for a user with the login 
name of John Public would be stored on the server in a file called John_0020Public.fdf because 
the space in the name is translated as a hexadecimal 0x0020. On Macintosh OS 9.0 and 9.1, there is 
a limit of 31 characters for a file name. So it is important to note that users with many spaces, or 
non-alphanumeric characters in their user name may exceed the maximum allowable characters for 
a file name in these systems.

Acrobat does not use a checkout or locking mechanism for comment files. Therefore enterprises 
should not allow multiple users to share the same user name; otherwise users will lose the com-
ments entered by other people.
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2.2 Security

Acrobat controls access by allowing comments to be uploaded only as your login name and only if 
the login name has permission to create files on that server. In the case of a default login name, as 
mentioned in the Identity section, the comments would be uploaded as GUEST.fdf. If there were 
more than one person logged in as “GUEST” the comments of each user would be saved to the same 
file. 

Acrobat does not verify that the user has write privileges to either the root or hash directories. If 
the user does not have write privileges, or the directory does not exist, then Acrobat will display an 
error message stating that the comments could not be saved and uploaded.

2.3 Data Structure

When the user opens a PDF in the browser, Acrobat reads the URL from the network layer, and then 
uses Domain Name Servers (DNS) to translate the name to an IP address. The DNS conversion 
guarantees that the comments will be stored in the correct repository regardless of whether or not 
the users use the same URL to access the collaboration document. Acrobat then takes the converted 
URL and makes an MD5 hash. For example: http://www.adobe.com/docs/foo.pdf would be 
converted to http://152.30.132.12/docs/foo.pdf, which would hash into 
UAtOJErFgHsL2xbLvPPJgC. More information on MD5 hash can be found in RFC 1321 or in many 
places on the web, such as http://www.ietf.org/rfc/rfc1321.txt.

Note: There is no way to reverse the MD5 hash to obtain the URL.

Do not change the location of the collaboration document until the period of collaboration is over. 
The folder names are based on the URL of the original document. If the location of the collabora-
tion document is changed and more comments are added, the new comments will not be saved in 
the same location as the initial comments. 

When working with multiple versions of a document, name each version differently; otherwise the 
comments will not align properly. In the example above, the MD5 hash for 
http://152.30.132.12/docs/foo.pdf is UAtOJErFgHsL2xbLvPPJgC, while the MD5 hash for 
http://152.30.132.12/docs/foo2.pdf is 1N2AwJKLt6BxpzjHp4_W7B. If one was to revise 
foo.pdf and place the updated document in the same location without changing the file name to 
reflect the version, the comments saved under that hash would not correlate to the new document. 
Highlighting may exist where there are no longer any words, or there may be line drawings correct-
ing a diagram that is now on another page.

2.4 Online Commenting

Once you have set your Online Comments Server Preference, the process of commenting on docu-
ments is the same. To begin commenting on the collaboration document, simply open your web 
browser and navigate to the URL where the document is located. The complete set of Acrobat 5.0 
Online Comments 5

http://www.ietf.org/rfc/rfc1321.txt


Online Comments
comments tools is available on the toolbar. The following are Online Commenting specific actions 
on the toolbar:

• Show Comments/Hide Comments:  Clicking this button will hide all annotations on the docu-
ment, including annotations that reside in the original collaborations document. 
Important: Acrobat only uploads visible comments to the server. Therefore, if the user is in 
"Hide Comments" mode when they click "Upload Comments," the result will be that all of their 
comments will be cleared, or removed, from the server. 

• Download Comments: Clicking this button will insert any new comments made by others dur-
ing your collaboration session.

• Upload Comments: Clicking this button will save your comments to the designated repository, 
and make them available for other members of your collaboration session to download.

• Upload and Download Comments: Clicking this button combines the actions of the two previ-
ously described buttons.

Once you have finished commenting, click on either the Upload Comments or Upload and Down-
load Comments button to save your comments. The following message indicates that Comments 
have been uploaded successfully:

Your comments will be automatically uploaded to the repository if you close either the browser 
window or Acrobat, or navigate to a different web page.

2.5 The Network Folder Repository

This repository type does not require a web server, a database, or any CGI code; therefore it is the 
easiest to set up. In this type, online comments are saved to a network drive or a local hard drive, 
instead of a web server or a database. The collaboration document is placed somewhere on the web. 
When users open and comment on the document, Acrobat creates an MD5 hash of the document 
URL, and each person’s comments are saved in the hashed sub-folder as an individual FDF file. 

2.5.1 Prerequisites

The following are server requirements for setting up the Network Folder repository: 

• A network folder must be chosen to store the comments. This folder must be accessible and 
allow write access to all the individuals commenting on the document.

The following are Network Folder repository requirements for the client:

• All users must have Apple Macintosh OS 9.0, 9.0.4, or 9.1 or Microsoft Windows 95 OSR 
2.0, Windows 98, Windows NT 4.0, Windows Millennium Edition, or Windows 2000.

• The document must be placed in a location accessible to all commenting users. 
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• Optional: A local drive may also be used to store the comments, although in this case, com-
ments may only be made and viewed by one person unless the access to that disk is shared 
with the network.

2.5.2 Manually Setting the Network Folder Preference

Let’s use the following scenario as an example, John Public and Jane Doe will be commenting 
on a document called http://www.adobe.com/docs/foo.pdf, and the online comments will 
be held in a folder called F:\Adobe\collab\annots\. To select the server:

1. Start Acrobat, and select Edit > Preferences > General > Online Comments

2. Change the Sever Type to Network Folder, then use the Choose button to browse to the net-
work folder where the comments are to be held.

When John Public and Jane Doe create comments and upload them to the server, Acrobat cre-
ates a hash folder and saves their comments as: 

F:\Adobe\collab\annots\48dsn30fhbfw\jpublic.fdf and 
F:\Adobe\collab\annots\48dsn30fhbfw\jdoe.fdf

Note: This example uses drive letters, however Acrobat supports UNC paths as well, for 
example the path could also be \\diskfarm\collab\annots\48dsn30fhbfw.
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2.5.3 Automatically Setting the Network Folder Preference

The store type for Network Folder is FSFDF. An FDF can be created to set the online comment 
server settings. The following script sets the repository to \\fileserver\shared\collab. Note 
that in the Collab.setStore, the second argument is a device independent path representation 
of the UNC path listed above. Please refer to the File Specification Strings section of the PDF 
Reference Manual for more information on device independent paths.

Sample script1:

%FDF-1.2

%âãÏÓ

1 0 obj

<<

/FDF

<<

/F (http://nefandous/pdfs/settingsupdated.pdf)

/JavaScript

<<

/After 2 0 R

>>

>>

>>

endobj

2 0 obj

<<

>>

stream

Collab.defaultStore = "FSFDF";

Collab.setStoreSettings("FSFDF", "/fileserver/shared/Collab/");

endstream

endobj

trailer

<<

/Root 1 0 R

>>

%%EOF

In this sample script, http://nefandous/pdfs/settingsupdated.pdf is the PDF that opens 
in the browser after the collaboration settings have been set in Acrobat. This PDF file name and 
the store settings are the two things that should be modified in this FDF to suit your particular 
needs.

1.Please note the this script was formatted to fit on the page, and cannot be used “out of the box.” There should be no hard returns within 
a string.
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2.6 The Microsoft Web Discussions Repository

Microsoft Web Discussions repository type allows users to share comments on a document in a way 
similar to a threaded discussion. Users can create topics and reply to others. 

This repository type is not available for Apple Macintosh users.

2.6.1 Prerequisites

The following are server requirements to configure the Web Discussions repository:

• Microsoft Office Server Extensions must be installed on the server. These are available with 
several Microsoft server products, including Microsoft Office 2000. 

• Either the Microsoft Management Console (MMC) or the Personal Web Manager (PWM) 
must be installed on the server.

The following are Web Discussions repository requirements for the client:

• Users must have Microsoft Office 2000 and Microsoft Windows 95 OSR 2.0, Windows 98, 
Windows NT 4.0, Windows Millennium Edition, or Windows 2000.

• All commenting users must have access to the server to be used as the discussions server.

2.6.2 Manually Setting the Discussion Server Preference

Let’s continue with our scenario with John Public and Jane Doe. They will be commenting on a 
document called http://www.adobe.com/docs/foo.pdf, the online comments will be held on 
the discussion server and are associated with the URL http://www.adobe.com/docs/foo.pdf.

1. Start Acrobat, and select Edit > Preferences > General > Online Comments.

2. Change the Sever Type to Web Discussions.
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3. Use Microsoft IE to select, or change, the Web Discussions Server. 

2.6.3 Data Storage

The comments data is stored on a string that describes the comment. Each single comment is a 
discussion item and that discussion item is composed of a string, which is JavaScript descrip-
tion of the comment. Acrobat uses a COM object to interface with the Web Discussions server. 
The parameters are the URL and the action, so for http://adobe.sample.com/foo.pdf, if the 
action is Get comment , Acrobat will continue to call Get comment until the COM object says 
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there are no more. The COM object sees the comments as a series of discussion threads.

Due to restrictions inherent in this repository type, comments containing binary attachments, 
such as sound or file attachments, are limited. If the discussion item contains binary data, Acro-
bat converts the binary stream into a hex stream, then splits it into smaller pieces, if necessary, 
to comply with the 64K byte maximum size of a discussion item. Web Discussions does not 
guarantee the order in which the messages are returned, so if the stream is separated into more 
than one discussion item, Acrobat posts the first part of the comment as a top-level discussion 
thread, and then the second part as a reply to this thread, and the third part as a reply to the 
reply, and so on. This is to ensure that the order of the stream will remain intact .

Users who wish to use the feature from the browser and use the discussion threads as they were 
intended, may not wish to see all of the Acrobat Comments associated with this page. For this 
reason, Acrobat stores comments slightly “off to the side.” Acrobat adds a non-existent new 
folder, /ACData, onto the URL when it gives the COM object the URL so there is no conflict. In 
order for the user to see the messages that Acrobat stores on the Web Discussions server, the 
user would have to surf to http://www.adobe.com/docs/foo.pdf/ACData. This folder does 
not actually exist, however Internet Explorer’s discussion window will now show all of com-
ments that Acrobat has stored on the Web Discussion server for the URL 
http://www.adobe.com/docs/foo.pdf/ACData.

2.6.4 Automatically Setting the Web Discussions Preference

The store type for Web Discussions is WD. An FDF can be created to set the online comment 
server settings. 

Sample script2:

%FDF-1.2

%âãÏÓ

1 0 obj

<<

/FDF

<<

/F (http://nefandous/pdfs/settingsupdated.pdf)

/JavaScript

<<

/After 2 0 R

>>

>>

>>

endobj

2 0 obj

2.Please note the this script was formatted to fit on the page, and cannot be used “out of the box.” There should be no hard returns within 
a string.
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<<

>>

stream

if(app.platform == "WIN")

  Collab.defaultStore = "WD";

else

  app.alert("The Web Discussions annot store in only available on 
Windows!");

endstream

endobj

trailer

<<

/Root 1 0 R

>>

%%EOF

In this sample script, http://nefandous/pdfs/settingsupdated.pdf is the PDF that opens 
in the browser after the collaboration settings have been set in Acrobat. This PDF file name and 
the store settings are the two things that should be modified in this FDF to suit your particular 
needs.

2.7 The Database Repository

This repository type allows users to speak directly to a SQL server database, making it a true enter-
prise solution for online commenting. This repository type uses a new technology called Acrobat 
DataBase Connectivity (ADBC), which allows Acrobat JavaScript access to a SQL database using 
architecture similar to Object DataBase Connectivity (ODBC). For more information on ADBC, see 
the Acrobat Forms JavaScript Object Specification at http://partners.adobe.com/asn/devel-
oper/technotes/acrobatpdf.html, and for more information on ODBC, see Microsoft’s technical doc-
umentation at http://www.microsoft.com/data/odbc/default.htm.

The Database repository type is not currently available for Macintosh users.

2.7.1 Supported Databases

Online Comments is currently supporting Microsoft SQL Server, Oracle 7, and Oracle 8i.

2.7.2 Prerequisites

The following are Database repository requirements for the client:

• Users must have Microsoft Office 2000 and Microsoft Windows 95 OSR 2.0, Windows 98, 
Windows NT 4.0, Windows Millennium Edition, or Windows 2000.

• If using a Microsoft SQL server, a SQL driver must be present on the client machine. This 
can be added through the installation of Office 2000 or MS SQL client software. If using an 
Oracle database, the Oracle client software must be installed on the client, and 
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TNSNAMES.ORA file must be in %ORACLE_HOME\network\admin.

2.7.3 Manually Setting the Database Repository Preference

The individual Information Systems department should configure and name the database to best 
suit their particular needs. See the Data Storage section for information on how Acrobat stores 
comments.

If users are to manually set the Server Preferences, the scenario is similar to the other prefer-
ences. John Public and Jane Doe will be commenting on a document called 
http://www.adobe.com/docs/foo.pdf, and in this example, the online comments will be 
held in a database called CollabDB.

To select the server:

1. Start Acrobat, and select Edit > Preferences > General > Online Comments

2. Change the Sever Type to Database, and type in the string that points to the database where 
the comments will be held.

When John Public and Jane Doe create comments and upload them to the server, Adobe creates 
a table in the database named the MD5 hash of the URL and saves each comment as a row in 
that table. 
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2.7.4 Automatically Setting the Database Preference

The store type for Database is DB. An FDF can be created to set the online comment server set-
tings. The following script sets the default string. 

Sample Script3:

%FDF-1.2

%âãÏÓ

1 0 obj

<<

/FDF

<<

/F (http://nefandous/pdfs/settingsupdated.pdf)

/JavaScript

<<

/After 2 0 R

>>

>>

>>

endobj

2 0 obj

<<

>>

stream

if (app.platform == "WIN")

{Collab.defaultStore = "DB"; Collab.setStoreSettings("DB", 
"DRIVER={SQL Server};SERVER=qui;UID=sa;PWD=;DATABASE=acrocollab");}

else

app.alert("The ADBC annot store is only available on Windows!");

endstream

endobj

trailer

<<

/Root 1 0 R

>>

%%EOF

In this sample script, http://nefandous/pdfs/settingsupdated.pdf is the PDF that opens in 
the browser after the collaboration settings have been set in Acrobat. This PDF file name and 
the store settings are the two things that should be modified in this FDF to suit your particular 
needs.

3.Please note the this script was formatted to fit on the page, and cannot be used “out of the box.” There should be no hard returns within 
a string.
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2.7.5 Data Storage

Acrobat creates a table for each collaboration document. The name of that table is the MD5 hash 
of the document’s URL. This table contains five columns of information:

• AUTHOR – The identity of the commentor.

• PAGE – The page number the comment is on.

• NAME – An Acrobat generated name.

• CONTENTS – A JavaScript description of the comment.

• DATA – This is used for binary data.

Each comment is stored as one row in the table, as a JavaScript representation of the comment. 

Sound and file attachments are stored as binary blobs, and are not to exceed 2 Gigabytes per 
comment. 

2.8 The WebDAV Repository 

This is the only repository type that allows users on Microsoft Windows 2000 to use a Microsoft 
FrontPage Extended server, or an FTP server as an Online Comments Server. However, it is impor-
tant to note that with Microsoft Windows 2000, Acrobat uses a Microsoft COM object to access the 
WebDAV server. This COM object is not case-sensitive and has difficulty distinguishing between 
the user names JPUBLIC and jpublic.

2.8.1 Supported Versions

Online Comments is currently supporting WebDAV RFC2518, along with Apache 1.3.14, and 
IIS 5.0

2.8.2 Prerequisites

The following are server requirements to configure the WebDAV repository:

• Apache1.3.14 with mod_dav 1.0, or Microsoft IIS 5.0.

• IS department involvement is needed to ensure the collaboration environment is set up cor-
rectly.

• A site to store the comments is required. This location must be accessible to all the individ-
uals commenting on the document.

• The document must be placed in a location accessible to all commenting users.
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The following are WebDAV repository requirements for the client:

• Users must have Apple Macintosh OS 9.0, 9.0.4, or 9.1 or Windows 95 OSR 2.0, Windows 
98, Windows NT 4.0, Windows Millennium Edition, or Windows 2000.

• To use a FrontPage extended repository or an ftp repository, users must be running on 
Microsoft Windows 2000. 

• To use an Apache 1.3.14 server with mod_dav or Microsoft IIS 5.0 server, the client may be 
any of the above listed supported platforms.

2.8.3  Manually Setting the WebDAV Preference

To configure the WebDAV repository, you must first determine the root directory for the com-
ments, and then add DAV access. An example of how to add DAV access to an Apache server 
with mod_dav installed, would be to add the following code to the httpd.conf:

<Location /Collab>

Dav On

</Location>

See http://www.webdav.org for more information on setting up your web server to support Web-
DAV.

On the client side, let’s use the same example with John Public and Jane Doe. They will be com-
menting on a document called http://www.adobe.com/docs/foo.pdf, the online comments 
will be held in http://beta1.adobe.com868/Collab. To select the server:

1. Start Acrobat, and select Edit > Preferences > General > Online Comments

2. Change the Sever Type to WebDAV, then type in the location where the comments are to be 
held.
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When John Public and Jane Doe create comments and upload them to the server, Adobe creates 
a hash folder and saves their comments as: 

http://beta1.adobe.com868/Collab/UAtOJErFgHsL2xbLvPPJgC/jpublic.fdf and 
http://beta1.adobe.com868/Collab/UAtOJErFgHsL2xbLvPPJgC/jdoe.fdf

2.8.4 Automatically Setting the WebDAV Preference

The server must be set up to allow WebDAV access. See Section 2.8.3, Manually Setting the 
WebDAV Preference, for more information.

The store type for WebDAV is DAVFDF. An FDF can be created to set the online comment 
server settings. The following script sets the default store to ads, port 8383 with /Collab/ as 
the root. 

Sample Script4:

%FDF-1.2 
%âãÏÓ 
1 0 obj 
<< 

/FDF 
<< 

4.Please note the this script was formatted to fit on the page, and cannot be used “out of the box.” There should be no hard returns within 
a string.
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/F (http://nefandous/pdfs/settingsupdated.pdf) 
/JavaScript 
<< 

/After 2 0 R 
>> 

>> 
>> 
endobj 
2 0 obj 
<< 
>> 
stream 

Collab.defaultStore = "DAVFDF"; 
Collab.setStoreSettings("DAVFDF", "http://ads:8383/Collab/"); 

endstream 
endobj 
trailer 
<< 

/Root 1 0 R 
>> 
%%EOF

In this sample script, http://nefandous/pdfs/settingsupdated.pdf is the PDF that opens 
in the browser after the collaboration settings have been set in Acrobat. This PDF file name and 
the store settings are the two things that should be modified in this FDF to suit your particular 
needs.

2.8.5 Data Storage

Acrobat allows the underlying mechanism dealing with HTTP connectivity to determine if the 
server exists. If the DAV server is down or does not exist, the comments cannot be uploaded. 
Once the users have made the comments and attempt to upload them, Acrobat contacts the DAV 
server and receives a directory listing of the repository root using the command PROFIND. If the 
hashed name doesn’t exist, Acrobat will attempt to create one using the command MKCOL. If the 
command fails, Acrobat will return an error message stating that the online comments server is 
unavailable and the comments have not been saved.

If the hashed directory already exists or the MKCOL command was successful, then Acrobat will 
export the comments that belong only to the current user to an FDF file. For example if the cur-
rent user is logged in as JPublic, then Adobe would export only comments that are authored by 
JPublic to an FDF file named JPublic.fdf. This FDF file is then uploaded to the server using the 
PUT command. If the upload is successful, the Upload Comments button will be disabled. This 
set of commands only uploads the current users comments to the server. The user must press the 
Upload and Download Comments button, or the Download Comments button to view com-
ments uploaded by other users. Acrobat does not retrieve from the current user’s set of com-
ments from the server. It is assumed that the environment the user is working in does not have 
the same user at two different machines simultaneously.
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2.9 Using JavaScript to Set the Online Comments Server Type Preference Within a Docu-
ment

As an alternative to creating and FDF, and to avoid having to reset the server type and location for 
each collaboration session, the document itself can adjust the preferences and the network location 
using JavaScript. To accomplish this:

Select Tools > JavaScript > Document JavaScripts, create a name for your script, click on the Add 
button, and delete the function script that Adobe has inserted.

In its place, insert code similar to the following example for Network Folder:
Collab.setStoreSettings ("FSFDF","/F/Adobe/collab/annots/");
Collab.defaultStore = "FSFDF";

The first line associates the folder with the Network Folder server type. The second line makes Net-
work Folder the default server type. Note the use of a device independent path to the folder holding 
the comments. For more information on independent path names, see the PDF Reference Manual 
Version 1.3 (Second edition) available at http://partners.adobe.com/asn/developer/technotes/acro-
batpdf.html 

3.0 Off-Line Commenting

3.1 Working Off-line

When an online collaboration session is not possible, or convenient, for example when someone is 
traveling on a plane, comments can be made offline then uploaded to the server later. To work 
offline:

1. Open the document in a web browser.

2. Save a copy of the document to your local hard drive by clicking on the Saves a copy of the file icon in 
the Acrobat toolbar.

Now the document is saved to your local hard drive and is available for you to comment on at any 
time. Simply open the document in Acrobat and begin working. When you are finished comment-
ing, save the document locally. The document can be commented on multiple times offline as long 
as it is saved locally after each “session.” 

To upload your comments to the server:

1. Open your local copy of the collaboration document in Acrobat.

2. Click on File > Upload Comments.
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Note: When you are uploading the offline comments, you must do so from the same machine 
that was used to make the offline copy. If you move the offline copy to another machine, 
you can make and save comments, but the File > Upload Comments menu item will be 
disabled, therefore you would need to move the copy back to the original machine to 
upload the comments. 

If the file has been modified, it will be saved and then the offline copy will be closed. Acrobat will 
open the original PDF in the default web browser and import the comments that the current offline 

user owns5, and then all other user comments are downloaded from the server and displayed in the 
document. The following message will be displayed:   

Important: At this point the online repository has not been changed. The comments are simply being dis-
played. You must click on either the Upload Comments or the Upload and Download Comments button 
to save the offline comments to the repository on the server.

3.2 Off-line Data Storage

When saving the collaboration document off-line, Acrobat copies all of the comments from all 
users and stores them in the PDF file on the local disk. When the user resumes online comments, 
only the comments authored by that user will be uploaded to the server. Acrobat stores the descrip-
tion of the relationship between the local file and the URL of the original document from which it 
was saved, in the Acrobat Preferences. On Microsoft Windows, that information is stored in the 
Windows Registry, and on the Apple Macintosh is stored in the Preferences folder in the System 
Folder.

5. “Comments that the current offline user owns” is defined as comments where the Author field of the comment matches the current 
login identity of the Acrobat user.
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3.2.1 Automatic Upload

If after working offline, a user returns to the URL of the original document in the browser with-
out uploading the comments using File > Upload Comments, Acrobat will automatically import 
the offline comments to the PDF displayed in the browser. This will happen only if the offline 
document has been commented on, and if the offline document has been saved. The comments 
will not be uploaded to the server, however, until the user closes the document, or clicks either 
the Upload Comments or Upload and Download Comments. As with a manual upload, only 
the current user’s comments will be uploaded. When Acrobat has automatically uploaded com-
ments, a dialog box will appear notifying the user. 

Acrobat will automatically upload comments to a URL only once per PDF document per user. 

4.0 Troubleshooting

4.1 WebDAV

Problem:

Users are experiencing problems using the WebDAV online comments server. A warning dialog box 
is displayed stating that the online comments server could not be contacted, and the user is unable 
to surf to the site using Internet Explorer.

Possible Cause:

The Online Comments preference settings are incorrect. The user may have entered the Web-
DAV URL manually and made an error, for example: http://beta1.adobe.foo:8686/Col-
lab/ when it should be http://beta1.adobe.com:8686/Collab/.
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Solution:

The user needs to set up the Online Comments preferences correctly.

Problem: 

Users are experiencing problems using the WebDAV online comments server. A warning dialog box 
is displayed stating that the online comments server could not be contacted, however the user is 
able to use their browser to surf to the site.

Possible Cause:

Acrobat uses special HTTP commands, called DAV verbs, to communicate with the WevDAV 
server, and in some cases, a proxy server may not forward DAV verbs to the server.

Solution:

If your proxy server does not forward DAV commands, the network settings will need to be 
changed to allow a direct connection to the Online Comments Server. This can be accomplished 
in one of three ways:

1. The IS department could create a PAC script which directs HTTP commands for the Online 
Comments Server to bypass the proxy, and then set the user’s browser to use the PAC script.

2. Edit the settings in the user’s Internet Control Panel to bypass the proxy for the Online Com-
ments Server.

3. Edit the user’s settings in the Internet Control Panel to use a direct connection to the Inter-
net.

4.2 All Repository Types

Problem:

Acrobat is unresponsive after clicking on the Upload Comments or Upload and Download Com-
ments button.

Possible Cause: 

Acrobat cannot connect to the server. This could be because the server is down.

Solution:

This action will eventually time out and Acrobat will display a dialog stating that the server is 
unavailable. The server connections should be checked.

Problem:

Comments are intermittent. The symptom may be that a user participates in a session commenting 
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on a PDF, then tries again later and the comments are not present, however the comments are 
present again on a later try.

Possible Cause:

This is likely an IP translation problem. Sometimes a URL can translate to different IP 
addresses, depending on the configuration. For example: The lookup of the address for 
ftp.irs.gov the DNS server will sometimes return 192.239.92.41 and another time may return 
208.185.132.75. Since Acrobat uses the IP address to create the MD5 hash of the URL, if the IP 
address is sometimes returned differently, the MD5 hash will be incorrect.

Solution:

The solution is to use the IP address when specifying the URL. Using the IRS example, for 
users who want to comment on http://ftp.irs.gov/pub/irs-99/f1040.pdf, it would be best 
to use http://192.239.92.41/pub/irs-99/f1040.pdf.

Problem:

Users do not see each other’s Comments, yet they are able to Upload Comments on their own 
machine successfully.

Possible Cause:

The problem may be how the users are accessing the PDF on the file server. It is common prac-
tice on Windows to open PDF files in the browser rather than using the File>Open command in 
Acrobat. The user may surf to the file server using a UNC path such as 
\\fileserver\users\joesmith\foo.pdf, or they may mount a volume such as 
\\fileserver\users to k: and open the file using k:\joesmith\foo.pdf. To Acrobat’s Online 
Comments engine these are two different files because of the different file names, and the MD5 
hash of each file will be different.

Solution:

For users to effectively comment on documents that exist on file servers, all users must enter the 
file name exactly the same, including capitalization. Using a web page with a link to the PDF 
can best solve this problem.

Problem:

Comments do not appear to be uploaded from an offline copy.

Possible Cause:

The user has opened the offline copy in the browser instead of the Acrobat application. Offline 
commenting is only possible in the application.

Solution:

The user should upload the comments using the Upload Comments menu item.
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Problem:

All server settings are correct and the server is active, yet the user continues to receive the follow-
ing error message:

 

Possible Cause:

If using either Apple Macintosh 9.0 or 9.1, the user name may be longer than the maximum of 
31 characters for a file name.

Solution:

The user should shorten their user name to allow the FDF file name to conform with the maxi-
mum.

Problem:

Upload Comments button does not activate when double-clicking on an FDF that was saved by 
using Comments > Export Selected in the browser.

Solution:

Make a change to one of the comments and the button will activate.
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